System Administration Commands psrinfo(1M)
NAME
psrinfo - displays information about processors
SYNOPSIS
psrinfo [-p] [-v] [processor_id...]
psrinfo [-p] -s processor_id
DESCRIPTION
psrinfo displays information about processors. Each physical
processor may support multiple virtual processors. Each vir-
tual processor is an entity with its own interrupt ID, capa-
ble of executing independent threads.
Without the processor_id operand, psrinfo displays one line
for each configured processor, displaying whether it is on-
line, non-interruptible (designated by no-intr), spare,
off-line, faulted or powered off, and when that status last
changed. Use the processor_id operand to display information
about a specific processor. See OPERANDS.
OPTIONS
The following options are supported:
-s processor_id Silent mode. Displays 1 if the specified
processor is fully on-line. Displays 0 if
the specified processor is non-
interruptible, spare, off-line, faulted or
powered off.
Use silent mode when using psrinfo in shell
scripts.
-p Display the number of physical processors in
a system.
When combined with the -v option, reports
additional information about each physical
processor.
-v Verbose mode. Displays additional informa-
tion about the specified processors, includ-
ing: processor type, floating point unit
type and clock speed. If any of this infor-
mation cannot be determined, psrinfo
displays unknown.
When combined with the -p option, reports
additional information about each physical
processor.
OPERANDS
The following operands are supported:
processor_id The processor ID of the processor about
which information is to be displayed.
Specify processor_id as an individual pro-
cessor number (for example, 3), multiple
processor numbers separated by spaces (for
example, 1 2 3), or a range of processor
numbers (for example, 1-4). It is also pos-
sible to combine ranges and (individual or
multiple) processor_ids (for example, 1-3 5
7-8 9).
EXAMPLES
Example 1: Displaying Information About All Configured Pro-
cessors in Verbose Mode
The following example displays information about all config-
ured processors in verbose mode.
psrinfo -v
Example 2: Determining If a Processor is On-line
The following example uses psrinfo in a shell script to
determine if a processor is on-line.
if [ "`psrinfo -s 3 2> /dev/null`" -eq 1 ]
then
echo "processor 3 is up"
fi
Example 3: Displaying Information About the Physical Proces-
sors in the System
With no additional arguments, the -p option displays a sin-
gle integer: the number of physical processors in the sys-
tem:
> psrinfo -p
8
psrinfo also accepts command line arguments (processor IDs):
> psrinfo -p 0 512 # IDs 0 and 512 exist on the
1 # same physical processor
> psrinfo -p 0 1 # IDs 0 and 1 exist on different
2 # physical processors
In this example, virtual processors 0 and 512 exist on the
same physical processor. Virtual processors 0 and 1 do not.
This is specific to this example and is and not a general
rule.
EXIT STATUS
The following exit values are returned:
0 Successful completion.
>0 An error occurred.
ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:
____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Availability | SUNWcsu |
|_____________________________|_____________________________|
SEE ALSO
psradm(1M), p_online(2), processor_info(2), attributes(5)
DIAGNOSTICS
psrinfo: processor 9: Invalid argument
The specified processor does not exist.
|
|