System Administration Commands smc(1M)
NAME
smc - start the Solaris Management Console
SYNOPSIS
smc [ subcommand] [ args]
smc [ subcommand] [ args] -T tool_name [ -- tool_args]
DESCRIPTION
The smc command starts the Solaris Management Console. The
Solaris Management Console is a graphical user interface
that provides access to Solaris system administration tools.
It relies on Solaris Management Console servers running on
one or more computers to perform modifications and report
data. Each of these servers is a repository for code which
the console can retrieve after the user of the console has
authenticated himself or herself to the server.
The console can also retrieve toolboxes from the server.
These toolboxes are descriptions of organized collections of
tools available on that and possibly other servers. Once one
of these toolboxes is loaded, the console will display it
and the tools referenced in it.
The console can also run in a terminal (non-graphically),
for use over remote connections or non-interactively from a
script.
For information on the use of the graphical console, and for
more detailed explanations of authentication, tools, and
toolboxes, please refer to the Solaris Management Console
online help available under the "Help" menu in the Solaris
Management Console. To enable an NIS/NIS+ map to be managed
from the Solaris Management Console, you must use the smc
edit command to create a new toolbox for that map and enter
the information about your NIS/NIS+ server where necessary.
For instructions on creating a new toolbox, in the Solaris
Management Console Help menu, select "Contents," then "About
the Solaris Management Console Editor," then "To Create a
Toolbox."
subcommands
smc subcommands are:
open The default subcommand for the Solaris Management
Console is open. This will launch the console and
allow you to run tools from the toolboxes you load.
It does not need to be specified explicitly on the
command line.
edit The edit subcommand will also launch the console,
like the open subcommand. However, after loading a
toolbox, you will not be able to run the referenced
tools. Instead, you will be able to edit that tool-
box, that is, add, remove, or modify any tools or
folders in that toolbox.
OPTIONS
The following options are supported. These letter options
can also be specified by their equivalent option words pre-
ceded by a double dash. For example, you can use either -D
or --domain with the domain argument.
If tool_args are specified, they must be preceded by the --
option and separated from the double dashes by a space.
--auth-data file
Specifies a file which the console can read to collect
authentication data. When running the Solaris Management
Console non-interactively, the console will still need
to authenticate itself with the server to retrieve
tools. This data can either be passed on the command
line using the -u, -p, -r, and -l options (which is
insecure, because any user can see this data), or it can
be placed in a file for the console to read. For secu-
rity reasons, this file should be readable only by the
user running the console, although the console does not
enforce this restriction.
The format of file is:
hostname=host name
username=user name
password=password for user name
rolename=role name
rolepassword=password for role name
Only one set of hostname-username-password-rolename-
rolepassword may be specified in any one file. If the
rolename is not specified, no role will be assumed.
-B | --toolbox toolbox
Loads the specified toolbox. toolbox can be either a
fully-qualified URL or a filename. If you specify an
HTTP URL as, for example,
http://host_name:port/. . .
it must point to a host_name and port on which an
Solaris Management Console server is running. If you
omit port, the default port, 898, is used. This option
overrides the -H option.
-D | --domain domain
Specifies the default domain that you want to manage.
The syntax of domain is type:/host_name/domain_name,
where type is nis, nisplus, dns, ldap, or file;
host_name is the name of the machine that serves the
domain; and domain_name is the name of the domain you
want to manage. (Note: Do not use nis+ for nisplus.)
This option applies only to a single tool run in the
terminal console.
If you do not specify this option, the Solaris Manage-
ment Console assumes the file default domain on whatever
server you choose to manage, meaning that changes are
local to the server. Toolboxes can change the domain on
a tool-by-tool basis; this option specifies the domain
for all other tools.
-h | --help
Prints a usage statement about the smc command and its
subcommands to the terminal window. To print a usage
statement for one of the subcommands, enter -h after the
subcommand.
-H | --hostname host_name:port
Specifies the host_name and port to which you want to
connect. If you do not specify a port, the system con-
nects to the default port, 898. If you do not specify
host_name:port, the Solaris Management Console connects
to the local host on port 898. You may still have to
choose a toolbox to load into the console. To override
this behavior, use the -B option (see above), or set
your console preferences to load a "home toolbox" by
default.
-Jjava_option
Specifies an option that can be passed directly to the
Java runtime (see java(1). Do not enter a space between
-J and the argument. This option is most useful for
developers.
-l | --rolepassword role_password
Specifies the password for the role_name. If you specify
a role_name but do not specify a role_password, the sys-
tem prompts you to supply a role_password. Passwords
specified on the command line can be seen by any user on
the system, hence this option is considered insecure.
-p | --password password
Specifies the password for the user_name. If you do not
specify a password, the system prompts you for one.
Passwords specified on the command line can be seen by
any user on the system, hence this option is considered
insecure.
-r | --rolename role_name
Specifies a role name for authentication. If you are
running the Solaris Management Console in a terminal and
you do not specify this option, no role is assumed. The
GUI console may prompt you for a role name, although you
may not need to assume a role.
-s | --silent
Disables informational messages printed to the terminal.
-t
Runs the Solaris Management Console in terminal mode. If
this option is not given, the Solaris Management Console
will automatically run in terminal mode if it cannot
find a graphical display.
--trust
Trusts all downloaded code implicitly. Use this option
when running the terminal console non-interactively and
you cannot let the console wait for user input.
-T | --tool tool_name
Runs the tool with the Java class name that corresponds
to tool_name. If you do not specify this option and the
Solaris Management Console is running in terminal mode,
the system prompts you. If the Solaris Management Con-
sole is running in graphical mode, the system either
loads a toolbox or prompts you for one (see options -H
and -B).
-u | --username user_name
Specifies the user name for authentication. If you do
not specify this option, the user identity running the
console process is assumed.
-v | --version
Prints the version of the Solaris Management Console to
the terminal. In the graphical console, this information
can be found in the About box, available from the Help
menu.
-y | --yes
Answers yes to all yes/no questions. Use this option
when running the terminal console non-interactively and
you cannot let the console wait for user input.
EXAMPLES
Example 1: Printing a Usage Statement
The following prints a usage statement about the smc command
to the terminal window:
smc --help
Example 2: Passing an Option to Java
The following passes an option through to the Java VM, which
sets the com.example.boolean system property to true. This
system property is only an example; the Solaris Management
Console does not use it.
smc -J-Dcom.example.boolean=true
ENVIRONMENT VARIABLES
See environ(5) for a description of the following environ-
ment variable that affects the execution of the smc command:
JAVA_HOME If you do not specify this environment
variable, your PATH is searched for a suit-
able java. Otherwise, the /usr/j2se location
is used.
EXIT STATUS
The following exit values are returned. Other error codes
may be returned if you specify a tool (using -T tool_name)
that has its own error codes. See the documentation for the
appropriate tool.
0 Successful completion.
1 An error occurred.
ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:
____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Availability | SUNWmcc |
|_____________________________|_____________________________|
SEE ALSO
auths(1), java(1), profiles(1), roles(1), smcconf(1M),
attributes(5), environ(5), X(7)
|
|